Resolved
All systems are operating normally
Monitoring
From 18:31 (28 January) to 08:47 (29 January) (CET), our API experienced elevated response times. During this window, some requests took significantly longer than normal, which may have resulted in slower UI loads, delayed integrations, and intermittent client timeouts depending on retry behavior and timeout settings. The issue has been resolved and we're continuing to monitor the situation.